MaxMine Service Disruption

Incident Report for MaxMine

Resolved

We are pleased to report that we now consider this incident resolved.

We can confirm that the Hardware Monitoring Page is now working as expected.

If you are experiencing any issues please contact MaxMine Support via the Service Desk.
Posted Apr 24, 2026 - 11:39 ACST

Investigating

We have identified an issue impacting loading of the Hardware Monitoring page.

Our Engineers are currently in the process of investigating the root cause.
Posted Apr 24, 2026 - 10:29 ACST
This incident affected: Website and APIs.