MaxMine Service Disruption

Incident Report for MaxMine

Resolved

We are pleased to report that we now consider this incident resolved.

We can confirm that the system is now working as expected.

If you are experiencing any issues please contact MaxMine Support via the Service Desk.
Posted Jun 03, 2026 - 14:15 ACST

Monitoring

Our Engineering team have identified the root cause and deployed a fix.

We will continue to monitor the system, but we expect the service to now be fully restored.

We will provide another update in 15 minutes.
Posted Jun 03, 2026 - 14:00 ACST

Identified

We have identified an issue impacting loading of all client websites

Our engineering team is working quickly to implement a solution.

Another update will be provided in 15 minutes
Posted Jun 03, 2026 - 13:50 ACST
This incident affected: Website and APIs.